Outfits get bugged upon traveling

The only mod stopping your Sims from traveling to the abyss. Did you end up there anyway? We'll try to help.
Locked
doccykaaa
Reactions:
Posts: 2
Joined: April 22nd, 2019, 9:01 am

Outfits get bugged upon traveling

Post by doccykaaa » April 22nd, 2019, 9:39 am

Dear Simmers,

Every time I travel to China with my sim, he stops being able to change outfits. COMPLETELY!
He showers and bathes in his everyday clothes, he sleeps in his everyday clothes, etc. The "Change Outfit" command stops working as soon as I arrive to my destination (I can select what outfit I want to change into, but he "resets" as soon as I select anything) and some interactions that involves changing outfits stop working altogether. The problem stays when my sim returns home. If anyone has any idea what could be wrong, please help. ADDITIONAL INFO: I also have Dresser installed, and have 5 everyday outfit.

At the same time, I'm looking for Traveler v82 (phase SEVEN) for pach 1.63. For several reason, mostly old mod incompatibilities, I haven't and can't patch the game to a newer version. So if anyone has older versions of Traveler archived, please, don't hesitate to share them with me! :D

Thanks for the help, in advance!

User avatar
igazor
Organizer
Reactions:
Posts: 11706
Joined: April 8th, 2013, 6:00 pm
Answers: 32

Outfits get bugged upon traveling

Post by igazor » April 22nd, 2019, 11:26 am

Hi there. Can't say for certain, but it does sound like you have a mod or patch level compatibility issue of some kind there. If you are currently running a more recent (or much older, can't say which way this has gone yet) version of Traveler on Patch 1.63, it's going to be impossible to rule this kind of thing out. Ordinarily I would suggest a MasterController reset of this sim when it happens, and of your entire worlds if necessary, but that's not going to help with such incompatibilities or if sim corruption has already crept in. From the sound of it you would also be unable to run current versions of MC but also Overwatch and ErrorTrap, which while not cure-alls in every single case are pretty important in keeping our games running free of such issues.

I'm afraid the older versions of the mods are not available nor are they supported here any longer. With Traveler in particular, a LOT has changed, fixed, and been improved upon since v82 besides taking the final patches into account. May I ask please what sorts of mods you are using alongside of NRaas and what the other reasons are that preclude patching up to at least 1.67?

doccykaaa
Reactions:
Posts: 2
Joined: April 22nd, 2019, 9:01 am

Outfits get bugged upon traveling

Post by doccykaaa » May 9th, 2019, 7:57 am

Hello,
Thank you for your reply and sorry for my late response. According to what you wrote, it seems like I am unable to do anything. Regardless, I will try to move around some mods, just to see if I can get traveler to work as intended. Relativity and a few other of my nRaas mods are also "incompatible" with my game version, but they work without any issues, so I am still hoping it might be some other CC that interferes. :D

The funny thing I discovered in the meantime is that if I travel with other sims who are from a different household, and I set traveler to keep them inactive while on vacation, they have no problem undressing, changins, showering, etc...

To answer your question, I am using a lot of mods without any compatibility issues so far...except for the one I wrote about, obviously.
Some of the major ones:
  • -nRaas Vector, Traffic, Tempest, Relativity, Master Controller, Dresser, Career
  • -Oniki's KinkyWorld
  • -Tons of clothing and accessories and skins and other CAS things...
  • -A few overrides and sliders, plus a few usable in-game objects (mostly these are the reason I don't update my game)
Have a nice day! :)

User avatar
Chain_Reaction
Site Admin
Reactions:
Posts: 5064
Joined: December 30th, 2011, 6:00 pm
Answers: 11
Contact:

Outfits get bugged upon traveling

Post by Chain_Reaction » May 9th, 2019, 9:54 am

Why is incompatible in quotes? We wrote the mods, we know if they are incompatible or not. Using them on older game versions is just asking for issues and corruption - like what you're experiencing. Maybe you don't see issues immediately with some of them but that doesn't mean anything. I also personally know Traveler was updated for 1.66 and will crash your game when the code that is missing from the core is accessed. Please do not use incompatible mods then ask for support, you're wasting everyone's time. Also KinkyWorld isn't compatible with these mods and is known to cause numerous problems and errors on it's own. Your game is basically a bomb at this point. When you've sorted things out you're welcome to ask for help, until then this thread is locked.

Locked