[SOLVED]Error with Young Again Elixir & Potion on another sim

A null value was encountered where this forum description was required.
Post Reply
Silvermetal
Reactions:
Posts: 10
Joined: February 11th, 2019, 3:11 pm

[SOLVED]Error with Young Again Elixir & Potion on another sim

Post by Silvermetal » March 4th, 2019, 5:39 pm

Hello, the background is this: Whenever my sim (Camilla Engel) tries to throw a young again elixir, or brings a young again potion mixed into a drink to some certain sims that are not from her household (using the mod "bring mysterious drinks to others" from icarus_allsorts at MTS), error trap fires and the outcome varies between:

Using young again elixir:
a) An error occurs to Camilla and she's reset and teleported back at home, while the sim that she threw the elixir at doesn't get affected by the elixir
b) The same error except this time the other sim DOES get affected by the elixir (which I consider acceptable after all)
c) No errors and everything goes smoothly.

Bringing a mysterious drink (Young again potion) to a sim:
a) Error trap fires and the sim gets reset and teleported back home, without been affected by the drink
b) No errors and everything goes smoothly

Notice that when it comes to the elixir from supernatural it is my sim the one that gets the error but when using the potion from generations it's the other sim that gets the error.

I haven't yet found any culprit or way to reproduce the error with a 100% acurracy (sometimes it just works, but usually it doesn't)

I have some error logs here, varying between with all my mods running, and using mostly Nraas mods:

Camilla Engel - Throwing Elixir - All mods running: https://pastebin.com/YyXNSgJu
Camilla Engel - Throwing Elixir - Nraas: https://pastebin.com/4HE9mXN5
Latosha (another sim) - Mysterious Drink - All mods: https://pastebin.com/t2yM1cMd

Now I realize I don't have a log for another sim with Nraas only mods. I hope this enough, if not, I shall add any other logs that you think convenient.

Any help in getting this young again stuff to work will be much appreciated :)
Last edited by Silvermetal on March 5th, 2019, 1:30 pm, edited 1 time in total.

User avatar
Chain_Reaction
Site Admin
Reactions:
Posts: 5058
Joined: December 30th, 2011, 6:00 pm
Answers: 11
Contact:

Error with Young Again Elixir & Potion on another sim

Post by Chain_Reaction » March 5th, 2019, 12:08 am

It's upset because they lack dream managers. Making them active then switching back out with dream catching enabled then try giving the potion may work.

Silvermetal
Reactions:
Posts: 10
Joined: February 11th, 2019, 3:11 pm

Error with Young Again Elixir & Potion on another sim

Post by Silvermetal » March 5th, 2019, 11:31 am

Unfortunately, it didn't work. First I enabled the Retain Dreams and Opportunities feature on the other sim's household using Story Progression, gave a potion, didn't work. Then I added that sim to my household, added that sim again to her old household, gave her a potion, didn't work, threw the elixir at her, didn't work.

Error logs look pretty much the same.
Latosha (other sim) drinking potion: https://pastebin.com/TAVxZ5S4
Camilla (my sim) throwing elixir: https://pastebin.com/5K9vSUM1

UPDATE:
After some testing, I tried something a bit different that worked. Instead of using SP retain dreams (which I preferred performance-wise), it seems that it wasn't working properly, promised dreams were not being retained for some reason, so instead I used master controller's retain dreams, which although it's performance heavy this did indeed retain the promised dreams when switching between households and both the elixir and potion worked fine.

Problem solved. Thank you :D

Post Reply