Omni Plant Script Error

Discuss how installing this mod should turn your sky orange here.
Post Reply
TiffWiki
Reactions:
Posts: 5
Joined: August 24th, 2014, 6:00 pm

Omni Plant Script Error

Post by TiffWiki » May 14th, 2017, 2:12 am

I believe this error originated after filling 100 omni plants with perfect plasma fruit then using DebugEnabler to progress their growth state and then adding a few SwiftGro Gardening Stations to trigger the growth on the other couple hundred perfect plants that Sunlight works on with the compositor and then removing the SwiftGro Gardening Stations in Edit Town afterwords.

When I returned to the game it told me some items were returned to me after editing the town and that they had been transferred to my family inventory. I looked and there were 100 perfect plasma fruit - the exact number fed to the omni plants.

I suspect then that this error happened as a result of the game giving them back to me and then when going to harvest the omni plants it thinks they should still have it, but they do not. "System.NullReferenceException: A null value was found where an object instance was required." Makes sense in that regard.

The full log file is here: http://nraas.wikispaces.com/file/detail ... or_Tiff-PC<u>05-14-2017</u>00-59-04__7173D9FF.xml

TiffWiki
Reactions:
Posts: 5
Joined: August 24th, 2014, 6:00 pm

Post by TiffWiki » May 14th, 2017, 2:15 am

I can't edit my post but the link above is obviously broken. You'll have to just copy/paste it. Maybe this will work

User avatar
igazor
Organizer
Reactions:
Posts: 11670
Joined: April 8th, 2013, 6:00 pm
Answers: 32

Post by igazor » May 14th, 2017, 7:29 am

Hi there. We'll have to wait for our developer to see and react to this thread, to confirm your suspicions about what OW had done/is trying to do here. In the meantime in case you have further script logs to add to this conversation, or for future reference, there is no need to link to them after they are uploaded. We can see who uploads files and when, so it's not difficult to match them to the post they are intended to go with.

We do ask though, if you could, please zip them up before uploading even if it's only one file. The raw xml ends up blasting in our faces in browser windows and is of course not readable that way, so we have to take some extra steps to work with single files like that. :)

TiffWiki
Reactions:
Posts: 5
Joined: August 24th, 2014, 6:00 pm

Post by TiffWiki » May 14th, 2017, 2:05 pm

I was going to just toss it into pastebin for you guys but looking in my folder it looks like there are several other errors from that session. The first several don't seem related nor relevant. The latter ones are pretty much identical cause I kept trying to harvest the plants. So I went ahead and uploaded those in a zip. The first few are likely from ErrorTrap because that was what was giving me the errors originally but then I exited out of game and updated all of my NRaas mods. I figured maybe more up-to-date NRaas mods might catch what's going on and fix it. The old ErrorTrap version would teleport me back home when I attempted to harvest one, like resetting my sim I think. The new version just tosses up an error and cancels any further harvesting actions. I wouldn't really mind a bunch of errors aside from that, cause harvesting 100 plants one by one would be kind of against the entire purpose of that lot. Harvest -> bulldoze -> replace from library -> harvest.

I wonder if feeding them all perfect plasma fruit again despite their being in harvest for the perfect plasma fruit would fix it? It would probably fix it temporarily I'd wager, and allow me to harvest them. But if I attempted to go into Edit Town and save the lot I would probably end up in the same situation. Though, I did originally save the lot with the older NRaas mods. So, it might be different with the newer ones. I updated MasterController from v130, MasterControllerCheats from v130, MasterControllerIntegration from v124, Relativity... was already v23 so I don't think I had to upgrade that. I'm not sure what version my ErrorTrap, Overwatch and Register were because I had them as loose files rather than in their respective folders. It looks like Register may have been v79. I don't have the folders archived for which versions of ErrorTrap and Overwatch had, which are probably the only really relevant ones.

User avatar
igazor
Organizer
Reactions:
Posts: 11670
Joined: April 8th, 2013, 6:00 pm
Answers: 32

Post by igazor » May 14th, 2017, 3:16 pm

The earlier script logs tell us that ErrorTrap was on v98 and Overwatch was on v116. These, especially OW, were from three years ago. But patch level requirements haven't moved all that much in three years even though the mods have continued to be updated. Our developer will still have to comment, but this does give him more information to work with at least.

User avatar
Chain_Reaction
Site Admin
Reactions:
Posts: 5054
Joined: December 30th, 2011, 6:00 pm
Answers: 11
Contact:

Post by Chain_Reaction » May 16th, 2017, 6:59 am

Removing the gardening stations caused the issue but it's harmless. It just means those omni plants probably produced nothing when harvested.

TiffWiki
Reactions:
Posts: 5
Joined: August 24th, 2014, 6:00 pm

Post by TiffWiki » May 16th, 2017, 12:06 pm

Oh they give me 3 or 4 perfect plasma fruit when harvested.

Post Reply