PortraitPanel Is this actually a problem or is this how it's supposed to be?

For all your questions regarding any mod that wasn't popular enough to get it's own forum above.
nobodyimportant
Reactions:
Posts: 18
Joined: March 25th, 2019, 11:20 am

Is this actually a problem or is this how it's supposed to be?

Post by nobodyimportant » May 2nd, 2019, 7:48 am

In every instance of any plumbot being displayed minus the actual sim world, the eye overlay is missing.
Is this normal? If not it's due to a mod, but what could possibly have caused this?
It's not a huge game breaking problem, but it is sortof really creepy to have empty eyes for them in interaction menus, in family portraits, in the portrait panel, and in the portrait picture.....
Image

User avatar
Chain_Reaction
Site Admin
Reactions:
Posts: 5050
Joined: December 30th, 2011, 6:00 pm
Answers: 11
Contact:

Is this actually a problem or is this how it's supposed to be?

Post by Chain_Reaction » May 3rd, 2019, 7:25 am

It could be that specific head but unless EA QA is worse than we thought, that doesn't look normal. Are you perchance playing with reduced graphics settings or an integrated graphics chip?

nobodyimportant
Reactions:
Posts: 18
Joined: March 25th, 2019, 11:20 am

Is this actually a problem or is this how it's supposed to be?

Post by nobodyimportant » May 5th, 2019, 9:12 pm

I mean it is an integrated GPU, but it's not a processor integrated GPU.
As in, it's not an IntelHD something, but an AMD Radeon M series thing
And i never had graphics glitches in the game at all.
My graphics settings aren't reduces, hell the shadows look way better than i expected, which i just noticed a couple days ago.
Reflections are on, etc.
It's also not that specific head. I tested it on all my plumbots and none ever had eyes in the portrait panel and in the menus.
It's the same for my sister too who uses a somewhat different mod loadout, so it's probably not that either. She's playing on a computer with an integrated GPU but it produces better graphics stuff than anything i can get since it's a bit newer.

Also, i could understand the fixed photographing for the portraits in the selection panel and in the sim panel being different from how things are normally rendered, but why is the menu face, which is animated, wearing current outfits and whatnot so different from the normal animation that eyes don't show up there?

nobodyimportant
Reactions:
Posts: 18
Joined: March 25th, 2019, 11:20 am

Is this actually a problem or is this how it's supposed to be?

Post by nobodyimportant » May 17th, 2019, 8:20 pm

No idea? Anyone?

User avatar
igazor
Organizer
Reactions:
Posts: 11656
Joined: April 8th, 2013, 6:00 pm
Answers: 32

Is this actually a problem or is this how it's supposed to be?

Post by igazor » May 18th, 2019, 8:39 am

We can't say for certain why the visuals are doing that to you currently. But at the end of the day, an integrated graphics chip is still that. It doesn't matter if one integrated chip is better or newer than another, without a dedicated card of sufficient strength and with sufficient throughput in play it's just not possible to rule out the impact.

We aren't EA here of course, but their take on it even back when the game was in develoipment would be that if the game plays in some manner on lower end hardware, then that itself is quite an accomplishment.

nobodyimportant
Reactions:
Posts: 18
Joined: March 25th, 2019, 11:20 am

Is this actually a problem or is this how it's supposed to be?

Post by nobodyimportant » May 21st, 2019, 9:03 pm

This wasn't lower end hardware though.
The problem is that i can turn visuals way up and it won't hurt the game much, but the eyes never get displayed.

User avatar
igazor
Organizer
Reactions:
Posts: 11656
Joined: April 8th, 2013, 6:00 pm
Answers: 32

Is this actually a problem or is this how it's supposed to be?

Post by igazor » May 21st, 2019, 10:45 pm

I did not say or mean to imply low end hardware. I said lower, a comparative, meaning that any integrated graphics chip is lower-end than a dedicated card that carries its own vram would be. You may feel free to disagree with that diagnosis as you wish, but am afraid given the number of views this thread has had, I'm not seeing a lot of other explanations for what you are experiencing flowing in.

Maybe I misunderstood what you meant by integrated, though. Which exact Radeon M series chip and processor are we talking about?

nobodyimportant
Reactions:
Posts: 18
Joined: March 25th, 2019, 11:20 am

Is this actually a problem or is this how it's supposed to be?

Post by nobodyimportant » May 24th, 2019, 12:57 pm

I mean it should have 1GB separate VRAM.
The IntelHD uses the CPU but this one doesn't.
6470 or something.

Either way this is beside the point.... my question is simply... why would every graphics thing work perfectly and fairly smoothly, except for one tiny little thing?

Isn't it possible that it's like with the sound where setting it to too high a sound quality will stop playback on radios for some reason if the soundboard is otherwise overused by the game?
Maybe i should try turning graphics all the way down...

Also none of this explains why the overlay (because it is just a simple overlay) disappears in pictures and in a certain type of 3D rendering.
Isn't there some mod that affects how these things are rendered? Doesn't Portrait Panel do exactly that?
Or does it just use preexisting EA code differently.
In the latter case however someone had to look at that code once right? So maybe they would know what on earth could make that code fail without any sort of error message.

Or maybe there is an error message i just have to look for it somewhere in some logs?
Last edited by nobodyimportant on May 25th, 2019, 8:55 am, edited 1 time in total.

User avatar
igazor
Organizer
Reactions:
Posts: 11656
Joined: April 8th, 2013, 6:00 pm
Answers: 32

Is this actually a problem or is this how it's supposed to be?

Post by igazor » May 24th, 2019, 3:21 pm

Okay. The 6470M is not an integrated card, sorry we did take a wrong turn back there but to be fair I was going by your use of the term "integrated" which is not how we usually use it here. That one is a dedicated card that does carry its own vram but not one that is strong enough to carry all aspects of the game seamlessly. I played on a 6770M from 2011 until just a few weeks ago, this is a card with a 128-bit bus width. The 6470M, if this is the one you have, has a 64-bit bus width and compares with what were the Nvidia GT 630 and 640s. The throughput for some functions is just not there and things can bottleneck when too much data is shoved through the 64 bit bus cards all at once even when it seems that other things are performing as they should. The same things happen on the much more recent Nvidia GT 930s, 940s, and 1030s (and I'm sure whatever the AMD equivalents of those might be).

We'll let our developer explain how PortraitPanel works. I really don't have any further inclination to explain why things we usually take for granted can so consistently happen out of order or not at all when the GPU cannot keep up with the instructions that the game is throwing at it. This is like the third or fourth such thread you have had on this forum and I don't feel like my responses are helping at all.

User avatar
Cassie
Reactions:
Posts: 44
Joined: October 17th, 2018, 5:17 am
Answers: 1

Is this actually a problem or is this how it's supposed to be?

Post by Cassie » May 24th, 2019, 4:14 pm

I have run some tests, but I haven't been able to replicate this, with or without mods, with various graphics settings. And before Igazor asks, yes, I did clear the cache files at every turn.

I have most NRaas mods, including Portrait Panel, so it seems unlikely any of those is causing your problem. If you disagree you will have to run your own tests with and without mods, but to me it seems more likely to be a hardware issue.

nobodyimportant wrote:
May 24th, 2019, 12:57 pm
Maybe i should try turning graphics all the way down...
I you haven't tried that yet, I would certainly recommend testing it.

nobodyimportant wrote:
May 24th, 2019, 12:57 pm
Or maybe there is an error message i just have to look for it somewhere in some logs?
AFAIK all error logs are in the root Sims3 folder. I didn't get any, but if your game is throwing an error, that is where you should look for it.

Post Reply