Community Lots in SV Populated by Ghosts?

The original catch all. General game help, banter, things you should probably put in the correct forum, This is the place.
Post Reply
User avatar
dreamsong1968
Reactions:
Posts: 9
Joined: January 6th, 2012, 6:00 pm

Community Lots in SV Populated by Ghosts?

Post by dreamsong1968 » March 11th, 2019, 9:08 pm

I started a new Sunset Valley after installing the entire suite (had been playing with only the base game installed for an extended period of time) and the game automatically added community lots to the world, as expected. However, after placing my newly created family on their home lot (the pre-made Pre-Fabulous) I went into edit town to do a few adjustments to the world. I wanted to play in a basic SV world without all of the additional lots, and my intent upon entering Edit Town mode was to remove all of the expansion lots.

Much to my surprise the expansion lots (though they are still showing as community lots) are inhabited by ghosts from the SV cemetery as though there is a household living on the lot! When I try to bulldoze the lots I get the message that normally pops up when you attempt to bulldoze a populated residential lot. Because many of these ghosts belong to resident family trees I don't want to annihilate them, and I'm not sure what is causing the issue or how to go about fixing it without causing another batch of problems and bugs. Is this a known problem? How do I fix it?

This has happened every time I've started a new SV since the installation and update--about 8-10 times.

Additional info:
All expansions are installed and updated to the latest patch. This is a fresh installation.
Mods installed--Anti-Magic Scroll, Careers, Debug Enabler, Decensor, Dreamer, Go Here, Master Controller, Once Read, Overwatch, Story Progression, Porter, Portrait Panel, Register, Tagger, Traffic, Traveler, Woohooer, and Written Word
CC: None--no store content installed

User avatar
gcgrad
Reactions:
Posts: 102
Joined: October 9th, 2013, 6:00 pm

Community Lots in SV Populated by Ghosts?

Post by gcgrad » March 12th, 2019, 1:02 am

Have you tried making the edits to the town before doing anything else, including before placing your new family?

User avatar
dreamsong1968
Reactions:
Posts: 9
Joined: January 6th, 2012, 6:00 pm

Community Lots in SV Populated by Ghosts?

Post by dreamsong1968 » March 12th, 2019, 3:14 am

gcgrad post_id=64433 time=1552366975 user_id=8527 wrote: Have you tried making the edits to the town before doing anything else, including before placing your new family?

The first few times, yes. Then I tried placing the family before editing. Even if I play the town for a couple of sim-hours the ghosts are still there occupying the lots.

User avatar
igazor
Organizer
Reactions:
Posts: 11176
Joined: April 8th, 2013, 6:00 pm
Answers: 23

Community Lots in SV Populated by Ghosts?

Post by igazor » March 12th, 2019, 4:05 am

dreamsong1968 - This might not be it, but what you are describing is what can happen if we load a saved game or start a new one from an existing game session by retreating to the Main Menu and not quitting to the desktop (or Origin if relevant) completely and reloading. It's a bug in the game where data in RAM from the first game session does not get cleared out entirely by not quitting and reloading in between, so it gets superimposed on the next world loaded up.

This can happen to anyone with or without mods, but the presence of Traveler makes it more likely and the effects can be more severe. I would never try to fix, save, or play a session forward once this kind of thing has happened.

User avatar
dreamsong1968
Reactions:
Posts: 9
Joined: January 6th, 2012, 6:00 pm

Community Lots in SV Populated by Ghosts?

Post by dreamsong1968 » March 12th, 2019, 4:18 am

igazor post_id=64436 time=1552377951 user_id=6716 wrote: dreamsong1968 - This might not be it, but what you are describing is what can happen if we load a saved game or start a new one from an existing game session by retreating to the Main Menu and not quitting to the desktop (or Origin if relevant) completely and reloading. It's a bug in the game where data in RAM from the first game session does not get cleared out entirely by not quitting and reloading in between, so it gets superimposed on the next world loaded up.

This can happen to anyone with or without mods, but the presence of Traveler makes it more likely and the effects can be more severe. I would never try to fix, save, or play a session forward once this kind of thing has happened.


Thanks for getting back to me about this. I will try again in the morning, but this happened the first time I booted the game up after installation.

User avatar
dreamsong1968
Reactions:
Posts: 9
Joined: January 6th, 2012, 6:00 pm

Community Lots in SV Populated by Ghosts?

Post by dreamsong1968 » March 12th, 2019, 5:51 pm

dreamsong1968 wrote:
March 12th, 2019, 4:18 am
igazor post_id=64436 time=1552377951 user_id=6716 wrote: dreamsong1968 - This might not be it, but what you are describing is what can happen if we load a saved game or start a new one from an existing game session by retreating to the Main Menu and not quitting to the desktop (or Origin if relevant) completely and reloading. It's a bug in the game where data in RAM from the first game session does not get cleared out entirely by not quitting and reloading in between, so it gets superimposed on the next world loaded up.

This can happen to anyone with or without mods, but the presence of Traveler makes it more likely and the effects can be more severe. I would never try to fix, save, or play a session forward once this kind of thing has happened.


Thanks for getting back to me about this. I will try again in the morning, but this happened the first time I booted the game up after installation.


I can't believe the solution to this was so simple! i just booted the game and started a fresh world and NO GHOSTS! Thank you, igazor!!

Post Reply